Cisco Routers - Example Configurations

* General Troubleshooting
show ip nat translations

* HSRP (Hot Standby Router Protocol)
Coming soon!

* NAT traffic from the Office to the Internet (source NAT)
interface GigabitEthernet0/0
 description Connection to Internet
 ip address 172.20.99.1 255.255.255.0
 ip nat outside
 duplex auto
 speed auto

interface GigabitEthernet0/1
 description Connection to Office
 ip address 192.168.80.1 255.255.255.0
 ip nat inside
 duplex auto
 speed auto

ip nat pool office 172.20.99.30 172.20.99.30 netmask 255.255.255.0
ip nat inside source list 20 pool office overload
access-list 20 permit 192.168.80.0 0.0.0.255
* NAT traffic from the New York office to various applications hosted at the Austin Data Center (source and destination NAT)

This is a useful configuration to use when you have duplicate subnets at different locations. In this example, the very popular 192.168.1.0/24 subnet was used in both the New York office (a recent acquisition) and the Austin data center. While the best long-term solution is to migrate one of the subnets to something different, this is a quick way to permit the folks in New York to access a few resources on the 192.168.1.0/24 network at the Austin data center. Of course, this probably means that the New York office will need to get a different DNS zone, which can add complexity. So, to reiterate, this is a tolerable temporary solution. Also, in case it isn't obvious, don't ever use 192.168.1.0/24. In fact, don't ever use 192.168.x.0/24, where x is a single digit.

interface GigabitEthernet0/0
 description Connection to New York Office
 ip address 172.20.115.1 255.255.255.0
 ip nat outside
 duplex auto
 speed auto

interface GigabitEthernet0/1
 description Connection to Austin Data Center
 ip address 192.168.70.1 255.255.255.0
 ip nat inside
 duplex auto
 speed auto

ip nat pool newyorkoffice 172.20.115.30 172.20.115.30 netmask 255.255.255.0
ip nat outside source list 20 pool newyorkoffice overload
access-list 20 permit 172.20.115.0 0.0.0.255
access-list 20 permit 172.20.111.0 0.0.0.255

ip nat inside source static 192.168.1.13  192.168.88.101
ip nat inside source static 192.168.1.21  192.168.88.102
ip nat inside source static 192.168.1.22  192.168.88.103
ip nat inside source static 192.168.1.23  192.168.88.104
ip nat inside source static 192.168.1.165 192.168.88.105
Related pages: